VGMdb
Go Back   VGMdb Forums > VGMdb Site Related > News and Announcements
Register FAQ Calendar Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
  #151  
Old Mar 8, 2011, 07:17 AM
Fearin Fearin is offline
Trusted Editor
 
Join Date: Dec 2009
Posts: 505
Default

Small heads up, musicbrainz .13 has been released which now includes proper rounding for track times, so for people who use both musicbrainz and vgmdb no double track times differing by 1 second and having off times added here.
Reply With Quote
  #152  
Old Mar 21, 2011, 02:30 PM
Secret Squirrel's Avatar
Secret Squirrel Secret Squirrel is offline
VGMdb Administrator
 
Join Date: May 2007
Location: Cleveland, OH
Posts: 5,934
Default

Is the VGMdb freedb working correctly for everyone?

I haven't used it in a while, and when I try it on a couple of CDs, I find that for one of them it can't find anymore (and it used to), and for the other, it only loads the Japanese tracklist no matter which server I point it to.
Reply With Quote
  #153  
Old Mar 21, 2011, 02:50 PM
Razakin's Avatar
Razakin Razakin is offline
Trusted Editor
 
Join Date: Sep 2007
Location: Hämeenlinna, Finland
Posts: 592
Default

I haven't been able to find anything with it lately, but then I could have my settings off in EAC.
__________________
vgmdb - serious business, only.
Reply With Quote
  #154  
Old Mar 21, 2011, 03:03 PM
the_miker's Avatar
the_miker the_miker is offline
Trusted Editor
 
Join Date: Nov 2007
Location: NY
Posts: 191
Default

Works perfectly for me. I ripped three CDs last night and it found all three with no probs.
__________________
https://twitter.com/the_miker
Reply With Quote
  #155  
Old Mar 21, 2011, 03:04 PM
Secret Squirrel's Avatar
Secret Squirrel Secret Squirrel is offline
VGMdb Administrator
 
Join Date: May 2007
Location: Cleveland, OH
Posts: 5,934
Default

Do you use EAC V1.0beta1 for your ripping?
Reply With Quote
  #156  
Old Apr 16, 2011, 05:15 PM
Metroid's Avatar
Metroid Metroid is offline
Senior Member
 
Join Date: Aug 2008
Location: UK
Posts: 231
Default

Did somebody spot the '1969' date bug already?
Reply With Quote
  #157  
Old Apr 16, 2011, 08:18 PM
Judge Ito's Avatar
Judge Ito Judge Ito is offline
Senior Member
 
Join Date: Sep 2007
Posts: 159
Default

I haven't been able to access the freedb from EAC since upgrading to 1.0. Old discs, new discs, any language.
Reply With Quote
  #158  
Old Apr 16, 2011, 08:37 PM
Metroid's Avatar
Metroid Metroid is offline
Senior Member
 
Join Date: Aug 2008
Location: UK
Posts: 231
Default

@Judge Ito: It is working for me. I'm using EAC V1.0 beta 1. The old way would not work. I tried other things and it did not work either. So the last resort was to point both the 'Metadata Plugin Options & freedb database options' to the VGMDB Freedb server. That solved the problem.

The '1969' date bug seems to be affecting both Foobar and EAC.
Reply With Quote
  #159  
Old Apr 17, 2011, 04:03 AM
Secret Squirrel's Avatar
Secret Squirrel Secret Squirrel is offline
VGMdb Administrator
 
Join Date: May 2007
Location: Cleveland, OH
Posts: 5,934
Default

Quote:
Originally Posted by Metroid View Post
@Judge Ito: It is working for me. I'm using EAC V1.0 beta 1. The old way would not work. I tried other things and it did not work either. So the last resort was to point both the 'Metadata Plugin Options & freedb database options' to the VGMDB Freedb server. That solved the problem.
Thanks! That fixes the problem I was having since upgrading to EAC V1.0.

What was your trick for getting it to work with Foobar?

Quote:
Originally Posted by Metroid View Post
The '1969' date bug seems to be affecting both Foobar and EAC.
Does this bug only occur with albums after 2009?
Reply With Quote
  #160  
Old Apr 17, 2011, 03:39 PM
Metroid's Avatar
Metroid Metroid is offline
Senior Member
 
Join Date: Aug 2008
Location: UK
Posts: 231
Default

Quote:
Originally Posted by Secret Squirrel View Post
Thanks! That fixes the problem I was having since upgrading to EAC V1.0.

What was your trick for getting it to work with Foobar?
No tricks, It is working fine, kind basic and probably you know, make sure tracks are in order and if somebody wants to add the vgmdb freedb server just change the server address to vgmdb.net in the Freedb Tagger interface nothing else is required, other than that I really have no idea as why is not working for some users. A fresh install to verify may be the best thing to do.

Quote:
Does this bug only occur with albums after 2009?
Yes, mainly new entries, but lately this is also affecting some edited tracklists.
Reply With Quote
  #161  
Old Jul 21, 2011, 02:12 AM
Cypher's Avatar
Cypher Cypher is offline
Senior Member
 
Join Date: Jun 2008
Posts: 159
Default

Mmm...I cannot seem to get the db working in foobar2000,but Mp3tag just works fine.
Wonder if it's only me or the support for foobar2000 is dead? :V

Last edited by Cypher; Jul 21, 2011 at 03:54 AM.
Reply With Quote
  #162  
Old Aug 15, 2011, 06:16 AM
the_miker's Avatar
the_miker the_miker is offline
Trusted Editor
 
Join Date: Nov 2007
Location: NY
Posts: 191
Default

This was working in EAC as of a few weeks ago but it's now giving a "Error - Server error" message. Any ideas?
__________________
https://twitter.com/the_miker
Reply With Quote
  #163  
Old Aug 15, 2011, 06:43 AM
Gigablah's Avatar
Gigablah Gigablah is offline
VGMdb Administrator
 
Join Date: May 2007
Posts: 2,397
Default

Not sure what's going on there, these test links seem to work:

http://vgmdb.net:80/cddb/en?cmd=cddb...o=TEST&proto=1
http://vgmdb.net:80/cddb/ja?cmd=cddb...o=TEST&proto=1
http://vgmdb.net:80/cddb/ja.utf8?cmd...o=TEST&proto=1
http://vgmdb.net:80/cddb/ja-Latn?cmd...o=TEST&proto=1

http://vgmdb.net/~cddb/en?cmd=cddb+r...o=TEST&proto=1
http://vgmdb.net/~cddb/ja?cmd=cddb+r...o=TEST&proto=1
http://vgmdb.net/~cddb/ja.utf8?cmd=c...o=TEST&proto=1
http://vgmdb.net/~cddb/ja-Latn?cmd=c...o=TEST&proto=1



EDIT: I think I found the problem -- if you access it via IP (some programs may be doing this internally), it goes to the wrong subdomain due to the order of the virtualhost configuration. I've fixed the config so that direct IP access works properly.
Reply With Quote
  #164  
Old Aug 15, 2011, 07:07 AM
dancey's Avatar
dancey dancey is offline
Trusted Editor
 
Join Date: Dec 2007
Location: New Jersey
Posts: 1,272
Default

I updated from EAC 1.0 beta2 24.04.11 to EAC 1.0 beta2 25.05.11 and it seems to work now. Strange.
Reply With Quote
  #165  
Old Aug 15, 2011, 10:48 AM
the_miker's Avatar
the_miker the_miker is offline
Trusted Editor
 
Join Date: Nov 2007
Location: NY
Posts: 191
Default

Quote:
Originally Posted by Gigablah View Post
I've fixed the config so that direct IP access works properly.
Yes you did! Working properly for me again, thanks. Now I can stay on my ancient version of EAC.
__________________
https://twitter.com/the_miker
Reply With Quote
  #166  
Old Aug 15, 2011, 03:07 PM
dancey's Avatar
dancey dancey is offline
Trusted Editor
 
Join Date: Dec 2007
Location: New Jersey
Posts: 1,272
Default

Ah, yes. EAC must be accessing by IP. Thanks Blah
Reply With Quote
  #167  
Old Aug 16, 2011, 05:16 AM
krelian75 krelian75 is offline
Senior Member
 
Join Date: Apr 2010
Posts: 120
Default

Dunno if this has been mentioned already, but when accessing recent albums (2010~2011), the date returned by freedb is often "1969".
(Accessing via mp3tag)
Reply With Quote
  #168  
Old Oct 24, 2011, 09:04 AM
Eriol-kun Eriol-kun is offline
Junior Member
 
Join Date: Jul 2008
Posts: 3
Default

How can an idiot such as me get this database working for recent iterations of fb2k? using the freedb plugin v0.6.4 I would like to know how to config it here. I tried this:

http://i.imgur.com/q5tfn.png

But I'd get this error:

http://i.imgur.com/rNEKk.png

So I know I'm doing something wrong because I'm an idiot. Help would be appreciated.
Reply With Quote
  #169  
Old Oct 24, 2011, 09:14 AM
Alcahest's Avatar
Alcahest Alcahest is offline
Senior Member
 
Join Date: Apr 2008
Posts: 156
Default

Hmm try:
Server: vgmdb.net
Port: 80
Address: /cddb or just cddb

Any luck?
Reply With Quote
  #170  
Old Oct 24, 2011, 02:07 PM
Secret Squirrel's Avatar
Secret Squirrel Secret Squirrel is offline
VGMdb Administrator
 
Join Date: May 2007
Location: Cleveland, OH
Posts: 5,934
Default

Quote:
Originally Posted by krelian75 View Post
Dunno if this has been mentioned already, but when accessing recent albums (2010~2011), the date returned by freedb is often "1969".
(Accessing via mp3tag)
This problem is now fixed!

Apparently we changed the format for saving dates in the album database, but never updated it in the CDDB code. So now, the year should be displaying correctly for all albums. Please let me know if there are any more issues. I understand (mostly) how the CDDB code works now, so I can probably solve some issues, but I'm not sure I can do much about compatibility with other external players or taggers without delving into their details.
Reply With Quote
  #171  
Old Nov 6, 2011, 06:21 AM
dancey's Avatar
dancey dancey is offline
Trusted Editor
 
Join Date: Dec 2007
Location: New Jersey
Posts: 1,272
Default

I'm not sure this is technically possible due to the information returned by freedb/cddb, but EAC v1.0 beta 1 and up now have a "Number Of CDs" and a "CD Number" field that you can fill out that will fill out the Total Discs and Disc Number fields, respectively. When pulling in from vgmdb, this is always pulling in as 1/1. Can this pull in total discs/queried disc#?
Reply With Quote
  #172  
Old Nov 6, 2011, 10:07 AM
Zorbfish Zorbfish is offline
Trusted Editor
 
Join Date: Sep 2007
Posts: 252
Default

Can't be done. freedb is a locked/frozen spec so there's no way to increase its functionality after the fact. I assume they are just using something that Gracenote has added to their CDDB database.
Reply With Quote
  #173  
Old Dec 5, 2011, 08:05 PM
EdgeKun's Avatar
EdgeKun EdgeKun is offline
Junior Member
 
Join Date: Jul 2008
Location: Hillsboro, OR
Posts: 5
Default

Hey guys. Been trying to use the VGMdb with dbPoweramp, and am really having no luck. (For all the boasted tags, dbPoweramp's sources are pretty god awful at tagging video game music) With EAC I have no issues connecting to the freedb, but trying to in dbPoweramp yields nothing. Said program seems to have no problem connecting to freedb.freedb.org, which makes me wonder if it simply has issues connecting to a site with "/" in the address.

Has anyone had any luck in connecting to the VGMdb freedb server using dbPoweramp? Regardless, thanks for your time peeps.
Reply With Quote
  #174  
Old Jan 13, 2012, 09:10 AM
Eriol-kun Eriol-kun is offline
Junior Member
 
Join Date: Jul 2008
Posts: 3
Default

Quote:
Originally Posted by Alcahest View Post
Hmm try:
Server: vgmdb.net
Port: 80
Address: /cddb or just cddb

Any luck?
Sorry for the really late reply, but I just gave up in frustration since nothing I did seemed to work. Just came back to see if I had more luck but nope.

Maybe it's a port config? But I doubt I should have problems with port 80...
Reply With Quote
  #175  
Old Feb 9, 2012, 01:37 PM
ZellSF ZellSF is offline
Junior Member
 
Join Date: Dec 2009
Posts: 3
Default

Is it a known issue that this doesn't handle track titles with "/" in them? What's after the "/" gets tagged as the artist.
Reply With Quote
  #176  
Old Feb 9, 2012, 04:44 PM
Gigablah's Avatar
Gigablah Gigablah is offline
VGMdb Administrator
 
Join Date: May 2007
Posts: 2,397
Default

I'm pretty sure the CDDB spec doesn't allow for per-track artist information, so that kind of behaviour is due to your tagging software.

(Edit: I'm a big fat liar, don't listen to me)
Reply With Quote
  #177  
Old Feb 9, 2012, 06:00 PM
ZellSF ZellSF is offline
Junior Member
 
Join Date: Dec 2009
Posts: 3
Default

Yeah, sorry, it is. I didn't check that because EAC and foobar2000 were both failing at it and I thought at least one of them would get it right.
Reply With Quote
  #178  
Old Feb 10, 2012, 04:45 AM
Zorbfish Zorbfish is offline
Trusted Editor
 
Join Date: Sep 2007
Posts: 252
Default

Actually it does. In the album title field the format is artist<space>/<space>title. A backslash can be used anywhere before the first backslash if it does not have spaces on either side of it. After the first backslash seperating the artist from the title a spaced backslash can be used again. Same with the track title fields, we can get limited per track credits but there was no way to when I first wrote it.
Reply With Quote
  #179  
Old Feb 10, 2012, 07:01 AM
Secret Squirrel's Avatar
Secret Squirrel Secret Squirrel is offline
VGMdb Administrator
 
Join Date: May 2007
Location: Cleveland, OH
Posts: 5,934
Default

So, we can probably fix this by replacing any instance of " / " in the track title we send with something else (maybe either remove the spaces, or try something like " - ").
Reply With Quote
  #180  
Old Feb 10, 2012, 08:44 AM
dancey's Avatar
dancey dancey is offline
Trusted Editor
 
Join Date: Dec 2007
Location: New Jersey
Posts: 1,272
Default

Quote:
Originally Posted by Secret Squirrel View Post
So, we can probably fix this by replacing any instance of " / " in the track title we send with something else (maybe either remove the spaces, or try something like " - ").
Bad idea, completely disagree.

Code:
TTITLEN:There must be one of these for each track in the CD. The track
	number should be substituted for the "N", starting with 0. This field
	should contain the title of the Nth track on the CD. If the disc is a 
	sampler and there are different artists for the track titles, the 
	track artist and the track title (in that order) should be separated
	by a "/" with a single space on either side to separate it from the text.
The proper way would be to return all track titles as " / %title", forcing the artist to always be null. It sounds like you are just returning "%title" now, so if %title happens to be something like "Happy / Sally", it splits it according to the file specificatoin. If you returned it as " / Happy / Sally", it should split out to a null artist and a "Happy / Sally" title.

That's my understanding of the issue without seeing the freedb code you're using.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Recover/access old login account quanta30 Questions and Comments 1 Oct 8, 2018 07:51 AM
How do you get the VGMdb freedb protocol to pull in? TimeLoss Questions and Comments 2 Oct 26, 2014 08:13 PM
Improved quicksearch and cddb/freedb emulation Gigablah News and Announcements 21 Sep 21, 2009 04:39 PM
RSS feeds partially implemented Gigablah News and Announcements 0 Dec 16, 2008 06:58 AM
CDDB and other options mrnutz Video Game Music Discussion 3 May 19, 2008 05:22 PM