VGMdb
Go Back   VGMdb Forums > VGMdb Site Related > News and Announcements
Register FAQ Calendar Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old Jan 21, 2018, 06:42 AM
Gigablah's Avatar
Gigablah Gigablah is offline
VGMdb Administrator
 
Join Date: May 2007
Posts: 2,361
Default Automatic HTTPS redirection

After testing HTTPS support for a couple of months, we've gone ahead and made it the default. Visitors will now be automatically redirected to the HTTPS site.

Some users may have issues with HTTPS, especially those who are still on older browsers or operating systems. Therefore we've implemented a fallback, accessible through the Preferences panel (the gear icon on the top right). Under the new "HTTPS Redirection" section, click on "Disabled".

As usual, add your feedback and bug reports to this thread!
Reply With Quote
  #2  
Old Jan 21, 2018, 11:23 AM
dancey's Avatar
dancey dancey is offline
Trusted Editor
 
Join Date: Dec 2007
Location: New Jersey
Posts: 1,095
Default

Fantastic, thank you!!

I am receiving an error with freedb querying, is that impacted by this? It's just saying: "Server error".

Current freedb server url:

http://vgmdb.net:80/cddb/ -- results in valid server address, but when querying, just returns "Server Error" in EAC.

Tried using:

https://vgmdb.net:80/cddb/ -- results in "Invalid server address !"
https://vgmdb.net/cddb/ -- results in "Invalid server address !"
Reply With Quote
  #3  
Old Jan 21, 2018, 02:38 PM
Gigablah's Avatar
Gigablah Gigablah is offline
VGMdb Administrator
 
Join Date: May 2007
Posts: 2,361
Default

I've tried adding an exclusion clause for cddb urls, could you try again? (keep using the http address)
Reply With Quote
  #4  
Old Jan 21, 2018, 02:40 PM
dancey's Avatar
dancey dancey is offline
Trusted Editor
 
Join Date: Dec 2007
Location: New Jersey
Posts: 1,095
Default

It is successful using the original http address (http://vgmdb.net:80/cddb/), thanks!
Reply With Quote
  #5  
Old Jan 21, 2018, 04:08 PM
dancey's Avatar
dancey dancey is offline
Trusted Editor
 
Join Date: Dec 2007
Location: New Jersey
Posts: 1,095
Default

Oops, posted this on the wrong thread:

Also seeing issues using the Omnibox search in Chrome with Unicode with redirecting from http --> https:

- Type "vgmdb.net ", which turns the bar into "Search vgmdb.net
- Type in any Unicode to search for, hit enter
- Searches for unicode with the http url, which redirects to the https url
- Search ends up searching for literals instead of Unicode

For example, searching for "小池郁江" lands me on a search page for "%E5%B0%8F%E6%B1%A0%E9%83%81%E6%B1%9F", which obviously has no results.
Reply With Quote
  #6  
Old Jan 21, 2018, 11:20 PM
Gigablah's Avatar
Gigablah Gigablah is offline
VGMdb Administrator
 
Join Date: May 2007
Posts: 2,361
Default

The opensearch configuration has been updated to use https so it's probably due to your browser caching the old version. Right click on the "Search VGMdb" box, select Edit Search Engines, and remove the vgmdb entry to force a refresh.
Reply With Quote
  #7  
Old Jan 22, 2018, 03:15 AM
dancey's Avatar
dancey dancey is offline
Trusted Editor
 
Join Date: Dec 2007
Location: New Jersey
Posts: 1,095
Default

Seems to be okay now. Couldn't right click the omnibox item so I went to Settings --> Manage Search Engines --> removed vgmdb.net (it was pointing to https), then browsed / searched around vgmdb.net manually til it came back up in the Omnibox. Seems to be okay! Thanks again!
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump